Sn0wbreeze V1.8 Coming Soon to Jailbreak iOS 4.1 Beta

The Newly released iOS 4.1 Beta for Developers can be Jailbroken on iPhone 3G and iPod Touch 2G, But Today the Developer of Sn0wbreeze has posted that Sn0wbreeze V1.8 Coming Soon (may be tonight) to Jailbreak iOS 4.1 Beta for iPhone 3GS (Old Bootrom), iPhone 3G, iPod Touch 2G on Windows..
Here’s the tweet from iH8sn0w:

Stay tuned for sn0wbreeze V1.8 BETA (Supports 4.1 Beta) [Pre-jailbroken on 4.0 required]

As you see in the tweet above, You have to be pre-jailbroken on iOS 4.. Which means that you have to Jailbreak iOS 4 using Sn0wbreeze or PwnageTool.

Google Ads:

Related Articles

Leave a comment